Issue136

Title Standalone: Assertion `map->l_init_called' failed!
Priority bug Status resolved
Superseder Nosy List desmoulinmichel, kayhayen, michaelbarton
Assigned To kayhayen Keywords standalone, wrong_execution

Created on 2014-05-12.13:17:37 by desmoulinmichel, last changed by kayhayen.

Files
File name Uploaded Type Edit Remove
log.txt michaelbarton, 2015-03-26.21:13:38 text/plain
Messages
msg1956 (view) Author: kayhayen Date: 2016-08-17.19:13:10
I have changed this, and now it should work nicely. Very few cases won't work, 
and libc is no more included.
msg1639 (view) Author: kayhayen Date: 2015-10-15.08:30:44
Hello,

which distribution are you compiling on, and which one running on. It seems as if going 
backwards is not binary compatible on Ubuntu, is that what you do there too?

Maybe it's bad idea to include libc. From the log Michael gave, it's a call to libc that fails, 
and probably lacks kernel support. Please try and remove it from the .dist folder and see if the 
crash goes away. Appears likely.

Yours,
Kay
msg1637 (view) Author: hamilyon Date: 2015-10-14.12:00:33
I can confirm this issue after moving distribution to another machine
msg1243 (view) Author: kayhayen Date: 2015-05-01.10:08:24
Assuming that the issue is fixed until proven wrong.
msg1212 (view) Author: kayhayen Date: 2015-04-20.08:37:01
I recently released a hotfix with a correction for a corruption of memory. It is 
quite possible, that these errors are a symptom of such corruption that is not a 
segfault.
msg1118 (view) Author: kayhayen Date: 2015-04-04.11:12:10
No, it won't. IU think I compiled validate-input, and it didn't immediately crash 
on given help output. Can you provide me with an example setup, so I can run it 
myself? Also, I didn't quite get, if this happens when run on Jessie on the same 
system, or only after transfer to another, and which one that would be.
msg1103 (view) Author: michaelbarton Date: 2015-03-30.17:18:21
Thank you for clarifying this. Would that mean if I changed the name of the binary this 
would solve the problem I experienced when using the compiled binary on a different 
system?
msg1095 (view) Author: kayhayen Date: 2015-03-28.05:18:47
The garbage output in the traceback is due to "__file__" being "validate-input", 
and there being a "validate-input" as a binary with that name later on.

So Nuitka ends up trying to read source code from the binary. Not good, and a bug 
by itself, that I also mean to fix.
msg1094 (view) Author: michaelbarton Date: 2015-03-28.05:16:11
Thank you for highlighting this. I'm afraid I don't completely understand though. Do 
you mean the reference to the main.py that doesn't exist in the build folder?
msg1091 (view) Author: kayhayen Date: 2015-03-28.04:11:07
Hello Michael,

one thing I just noticed, is this:

./build/validate-input 
Traceback (most recent call last):
  File "/data/home/hayen/repos/Py2C/t/input-validator/build/validate-input", line 6, in <module>
    R[�e�
  File "/data/home/hayen/repos/Py2C/t/input-validator/build/validate_input/main.py", line 6, in main
ImportError: No module named validictory

For tracebacks, the binary is used due to run time dependent __file__ value. That is most probably very 
unlikely what people want to happen. I of course know how to solve the ImportError. I just wanted to 
record the issue. Maybe if "__file__" is identical to the running binary name, we must not use that 
value then. Or maybe, it should point to a kind of "src" folder inside.

Yours,
Kay
msg1089 (view) Author: michaelbarton Date: 2015-03-27.18:14:34
I am using 0.5.11. I install this through pip.
msg1083 (view) Author: kayhayen Date: 2015-03-27.07:41:05
Hello Michael,

which version of Nuitka is this, the one to be in Jessie release, or current 
Nuitka as per downloads page on nuitka.net ?

Yours,
Kay
msg1082 (view) Author: michaelbarton Date: 2015-03-26.21:13:38
I am also having a similar problem. I am using debian jessie with a --standalone 
compiled program. I have attached the strace output for this error.

The github for this compiled binary is here - https://github.com/bioboxes/input-
validator
msg830 (view) Author: kayhayen Date: 2014-10-20.19:58:02
Lack of feedback.
msg689 (view) Author: kayhayen Date: 2014-06-23.07:41:04
Can you retry, I made changes related to rpath, removing it now. Could be that 
this was causing the issues for you.
msg665 (view) Author: kayhayen Date: 2014-05-21.07:01:40
So this should be that bug:

https://bugs.launchpad.net/ubuntu/+source/krb5/+bug/1231459

It's confirmed and unsolved. Did you update the Ubuntu in question, or is this a 
release version. When is this assertion triggered, at program end?
msg661 (view) Author: desmoulinmichel Date: 2014-05-20.10:43:05
Hi, 

Sorry for taking so much time to answer. I'm currently in a mission in Asia and
Internet is not always accessible.

I deleted libdl.so.2 but got exactly the same error, sorry.
msg651 (view) Author: kayhayen Date: 2014-05-13.05:46:04
Hello,

> However, if I change to Ubuntu 12.04 64 bits Python 2.7, it get :
>
> Inconsistency detected by ld.so: dl-close.c: 759: _dl_close: Assertion
> `map->l_init_called' failed!
>
> Is that to be expected ? I would imagine that running on the same archictecture
> and a similar Linux, the binary would work.
>
> Can I only run the binary on Ubuntu 14.04 ? Can I do something to make it more
> universal (like running on Ubuntu And Redhat) ?

The idea of standalone is to provide this. I am now suspecting that 
copying "ld.so" into the ".dist" folder, may not be necessary, or even a 
good idea. Can you delete it and try to run it then. It may well be that 
"ld.so" could be more closely tied to the kernel, making it non portable.

But as its interface is common, we can just not include it. If it helps 
for you, that is how I would go for this.

Yours,
Kay
msg650 (view) Author: desmoulinmichel Date: 2014-05-12.13:17:37
I compiled this script :

http://0bin.net/paste/yp3pWOJrM8vb5z7-#oZHVGvujyVpw8PsKCadbbNocSdwmi4/K5rK8SdHhlfw=

Using :

nuitka --recurse-all downloader.py --standalone

I can run the resulting binary on the same environnement (Ubuntu 14.04, 64bits,
python 2.7).

However, if I change to Ubuntu 12.04 64 bits Python 2.7, it get :

Inconsistency detected by ld.so: dl-close.c: 759: _dl_close: Assertion
`map->l_init_called' failed!

Is that to be expected ? I would imagine that running on the same archictecture
and a similar Linux, the binary would work.

Can I only run the binary on Ubuntu 14.04 ? Can I do something to make it more
universal (like running on Ubuntu And Redhat) ?

Cheers
History
Date User Action Args
2016-08-17 19:13:10kayhayensetstatus: chatting -> resolved
messages: + msg1956
2015-10-18 10:37:20kayhayensettitle: Assertion `map->l_init_called' failed! -> Standalone: Assertion `map->l_init_called' failed!
2015-10-15 08:30:44kayhayensetmessages: + msg1639
2015-10-14 12:00:33hamilyonsetstatus: resolved -> chatting
messages: + msg1637
2015-05-01 10:08:24kayhayensetstatus: chatting -> resolved
messages: + msg1243
2015-04-20 08:37:02kayhayensetmessages: + msg1212
2015-04-04 11:12:10kayhayensetmessages: + msg1118
2015-03-30 17:18:21michaelbartonsetmessages: + msg1103
2015-03-28 05:18:47kayhayensetmessages: + msg1095
2015-03-28 05:16:11michaelbartonsetmessages: + msg1094
2015-03-28 04:11:07kayhayensetmessages: + msg1091
2015-03-27 18:14:34michaelbartonsetmessages: + msg1089
2015-03-27 07:41:05kayhayensetstatus: chatting
messages: + msg1083
2015-03-26 21:28:47michaelbartonsetnosy: + michaelbarton
2015-03-26 21:13:38michaelbartonsetstatus: resolved -> (no value)
assignedto: desmoulinmichel -> kayhayen
messages: + msg1082
files: + log.txt
2014-10-20 19:58:02kayhayensetstatus: chatting -> resolved
messages: + msg830
2014-06-23 07:41:04kayhayensetassignedto: kayhayen -> desmoulinmichel
messages: + msg689
2014-05-21 07:01:40kayhayensetmessages: + msg665
2014-05-20 10:43:05desmoulinmichelsetmessages: + msg661
2014-05-13 06:09:14kayhayensetassignedto: kayhayen
keyword: + standalone
nosy: + kayhayen
2014-05-13 05:46:04kayhayensetstatus: unread -> chatting
messages: + msg651
2014-05-12 13:17:54desmoulinmichelsetkeyword: + wrong_execution
2014-05-12 13:17:37desmoulinmichelcreate