Issue199

Title Windows: Unknown error with mt.exe occurs.
Priority bug Status chatting
Superseder Nosy List jusan, kayhayen
Assigned To jusan Keywords compiler, windows

Created on 2015-04-18.15:59:51 by jusan, last changed by marc.jofre.

Messages
msg1379 (view) Author: marc.jofre Date: 2015-07-25.16:59:10
Hi Kay,

I would say that Studio is enough. Just, the user make sure to install the 
latest Scons software to avoid 2013 old issues

Best,

Marc
msg1374 (view) Author: kayhayen Date: 2015-07-25.10:36:00
Mark, are you saying that there is no "mt.exe" in proper MS Visual Studio 2010?

Because if there is not, that is probably kind of an issue to make clear to the 
user, if there is more to install than just the Studio.

Yours,
Kay
msg1298 (view) Author: marc.jofre Date: 2015-05-24.18:38:37
Hi,

Some tips:

Update to latest scons version

Tricks done to fix things:
In 64 bits machine:
In File SingleExe.scons add the following text in line 1162 after stdout = 
subprocess.PIPE
   ,shell=True
   
   Add to path: C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\x64 for 
finding mt.exe
   
Very important:
 - Run the command in the Visual Studio x64 Win64 Command Prompt (2010). Thus, 
open a Visual Studio x64 Command Prompt (2014), navigate to the folder 
..PythonGeneralController and execute for instance: nuitka --standalone --exe --
icon=C:/Users/mjofre/Desktop/productgeneraldistributables/softwaregeneralscripts
/PythonGeneralController/SIXSENSOLogoRGBicon.ico --recurse-not-to=numpy 
PythonGeneralControllerMain.py
 - When running nuitka with standalone option, set the working folder path to 
Windows path so that scons finds the libraries from relative path.
msg1297 (view) Author: dwzl Date: 2015-05-24.05:35:28
I tried with 0.5.14pre2 and the issue is the same.
msg1295 (view) Author: dwzl Date: 2015-05-23.04:46:56
I have the same issue (Nuitka version 0.5.13.1):

C:\git\scrap\>nuitka --recurse-all --standalone test_program.py
[....some warnings....]
WindowsError: [Error 2] The system cannot find the file specified:
  File "C:\Python27\Lib\site-packages\nuitka\build\SingleExe.scons", line 847:
    shell       = False
  File "C:\Python27\lib\subprocess.py", line 710:
    errread, errwrite)
  File "C:\Python27\lib\subprocess.py", line 958:
    startupinfo)

I can verify that mt.exe is available on my PATH.
msg1285 (view) Author: kayhayen Date: 2015-05-20.06:45:42
Can you retry and see what it says now?
msg1241 (view) Author: kayhayen Date: 2015-05-01.10:01:38
What MSVC version is this, normally Scons is supposed to find it without your
help, and then the "mt.exe" should be there as well. 

The new stable version outputs a nicer error that should tell us what is going
on exactly. So please retry with that version and report the error given.
msg1233 (view) Author: drueffer Date: 2015-04-23.19:51:10
Hi there, 

I had the same error on Windows. Checking
C:\Python27\Lib\site-packages\nuitka\build\SingleExe.scon I figured a subprocess
is trying to call mt.exe.

Make sure that you have the path to mt.exe in your system path: in my case it
could be found in: C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin
msg1201 (view) Author: jusan Date: 2015-04-18.15:59:51
Hi guys

I'm new on compiling python using nuitka.
I tried to compile python file and got below message

C:\Python27>C:\Python27\Scripts\nuitka  --recurse-all program.py
WindowsError: [Error 2] The system cannot find the file specified:
  File "C:\Python27\Lib\site-packages\nuitka\build\SingleExe.scons", line 1202:
    stdout = subprocess.PIPE
  File "C:\Python27\lib\subprocess.py", line 524:
    return Popen(*popenargs, **kwargs).wait()
  File "C:\Python27\lib\subprocess.py", line 711:
    errread, errwrite)
  File "C:\Python27\lib\subprocess.py", line 948:
    startupinfo)
History
Date User Action Args
2015-07-25 16:59:10marc.jofresetmessages: + msg1379
2015-07-25 10:36:00kayhayensetmessages: + msg1374
2015-05-24 18:38:37marc.jofresetmessages: + msg1298
2015-05-24 05:35:28dwzlsetmessages: + msg1297
2015-05-23 04:46:56dwzlsetmessages: + msg1295
2015-05-20 06:45:42kayhayensetassignedto: kayhayen -> jusan
messages: + msg1285
2015-05-01 10:01:38kayhayensetmessages: + msg1241
keyword: + windows, compiler
title: Program compilation with all modules embedded -> Windows: Unknown error with mt.exe occurs.
2015-04-23 19:51:10drueffersetstatus: unread -> chatting
messages: + msg1233
2015-04-20 07:47:29kayhayensetpriority: urgent -> bug
2015-04-18 16:02:50jusansetassignedto: kayhayen
nosy: + kayhayen
2015-04-18 15:59:51jusancreate