Issue200

Title Standalone missing parts of tkinter
Priority bug Status chatting
Superseder Nosy List joakimo, kayhayen
Assigned To kayhayen Keywords standalone

Created on 2015-04-19.22:40:31 by joakimo, last changed by joakimo.

Files
File name Uploaded Type Edit Remove
Captura de pantalla de 2015-08-17 01:32:46.png ljrossi, 2015-08-17.04:41:47 image/png
Nuitka_failing.pdf joakimo, 2016-04-21.12:44:44 application/pdf
tcl_missing.pdf joakimo, 2015-04-19.22:50:17 application/pdf
threadtest.py joakimo, 2015-05-01.16:04:05 text/plain
Messages
msg1921 (view) Author: joakimo Date: 2016-04-21.12:44:44
Just thought I'd let you know:

The bug fix list for the last version looked promising, especially 
"Standalone: Added missing hidden dependencies for Tkinter module, adding 
support for this to work properly", so I decided to give it a new try.

However, this time the output doesn't work at all, see the attached 
document. Now I've downgraded back to version 0.5.14Pre2, since at least the 
generated output works there, as long as tcl/tk is copied to the deployment 
PC.
msg1430 (view) Author: ljrossi Date: 2015-08-17.04:41:47
I solve this manually coping folder tcl8.6 and tk8.6 that previsouly made with 
py2exe

to 

 C:/lib/tcl8.6
 C:/lib/tk8.6

Also any of the folders given in my screenshoot solves....not necesary to put 
on each folder.

Take many hours to solve this....I will quite nice that nuitka worked with 
tkinter... that is distributed with python itself.
Thanks
msg1429 (view) Author: ljrossi Date: 2015-08-17.02:25:40
Same problem with nuitka 5.14.3 ,  runing on Windows XT ,  python34 ,boths 32bits
msg1254 (view) Author: joakimo Date: 2015-05-01.16:04:05
Here's a small script using key elements from my GUI/app design, it fails 
the same way as the original, (now compiled with Nuitka version 0.5.13.0).

I have tried simply copying parts of tcl from the developer machine to the 
PC without Python, (no adding to path/registry), and both the example script 
and the original app seem to run well with the following:

C:\Python34\tcl\tcl8.6\*.* (no folders, just the files)
C:\Python34\tcl\tk8.6\*.* (all files, plus folder below)
C:\Python34\tcl\tk8.6\ttk\*.* (all files)

I guess I could probably delete several of the files without causing 
trouble, but in many cases that would just be because I don't use those 
widgets in my GUI.

On the deployment PC the placement is as follows:

C:\nuitkatest\threadtest.dist
C:\nuitkatest\lib\tcl8.6
C:\nuitkatest\lib\tk8.6

Hope this helps. I suppose copying as above should not really be necessary 
since the tk/tcl dlls are already included in Nuitka's output, I would 
rather think some path must be changed somehow in compilation. But as I'm 
sure you can tell; this is far from my field of expertise...
msg1245 (view) Author: kayhayen Date: 2015-05-01.10:16:10
Indeed, there is a tcl folder top level in Python3.4 for me too. It's pretty vast, 
and contains examples, demos... not sure what to include. Can you provide a minimal 
example maybe, it seems merely importing tkinter does not trigger it. 

So I don't reproduce it yet.
msg1216 (view) Author: joakimo Date: 2015-04-20.11:03:53
Thanks for looking into this so swiftly!

The file referenced on top in the console print (gui.pyw) is my top-level 
Python script, location is correct. But there is no lib- or library-folder 
created in or near the .dist directory during compilation.
msg1207 (view) Author: kayhayen Date: 2015-04-20.06:29:46
Congrats on raising bug 200. :)

The path displayed is properly inside the ".dist" directory, right? So it seems 
that CPython there includes an installation of TCL that needs to be copied too, 
which is kind of evil thing to do. (On my Debian Linux, this just works, but 
likely because tcl is not part of the Python install, but separate.)

I am going to try including it.
msg1206 (view) Author: joakimo Date: 2015-04-19.22:50:17
Apparently the attachement didn't make it, so I'm trying again...
msg1205 (view) Author: joakimo Date: 2015-04-19.22:40:30
I have an application with a GUI made with tkinter. A standalone compiled 
version runs fine on the developer machine, but on a different PC with no 
Python installed nothing seems to happen.

By compiling a version with the console still enabled, I got a traceback 
saying that tcl can not be found, see the attached pdf. A GUI-less version 
of the same application runs fine on the same machine.

Nuitka version: 0.5.12.1 (32-bit)
Python Version: 3.4.3 (32-bit)
OS: Windows 7 (64-bit)
Compiler: VS Express 2013 for Desktop
History
Date User Action Args
2016-04-21 12:44:44joakimosetfiles: + Nuitka_failing.pdf
messages: + msg1921
2015-08-17 04:41:47ljrossisetfiles: + Captura de pantalla de 2015-08-17 01:32:46.png
messages: + msg1430
2015-08-17 02:25:40ljrossisetmessages: + msg1429
2015-08-17 02:24:15ljrossisetmessages: - msg1428
2015-08-17 02:23:48ljrossisetmessages: + msg1428
2015-05-01 16:04:05joakimosetfiles: + threadtest.py
messages: + msg1254
2015-05-01 10:16:10kayhayensetassignedto: kayhayen
messages: + msg1245
nosy: + kayhayen
2015-04-20 11:03:53joakimosetmessages: + msg1216
2015-04-20 06:29:46kayhayensetmessages: + msg1207
2015-04-19 22:50:17joakimosetfiles: + tcl_missing.pdf
status: unread -> chatting
messages: + msg1206
2015-04-19 22:40:31joakimocreate