Issue222

Title Windows: Visual Studio 2015 is not supported
Priority bug Status resolved
Superseder Nosy List grippa, kayhayen
Assigned To kayhayen Keywords windows

Created on 2015-07-29.01:51:54 by grippa, last changed by kayhayen.

Messages
msg1387 (view) Author: kayhayen Date: 2015-07-30.07:58:55
I just released it as 0.5.13.3, but since my desktop is broken, package releases 
may have to wait, but PyPI and RPMs ought to work some time later.
msg1386 (view) Author: grippa Date: 2015-07-29.14:18:37
Great.
What version is guaranteed to work right now?
msg1385 (view) Author: kayhayen Date: 2015-07-29.13:58:08
I pushed to factory changes to Scons that make it find Visual Studio 2015 too. I 
expect to make a release with it this week.
msg1383 (view) Author: grippa Date: 2015-07-29.02:35:18
This error might be caused by renaming 2.7 python.exe to python2.exe because 
my system became defaulted to 2.7 otherwise. After this I got no compiler 
found error. So I ran visual studio and installed c++ enviroment. After this 
still no compiler found. Ran all the command prompts and did all the 
suggestions I could find. Installed pywin, updated sons py 2.7 and 3.4. My 
whole pc is full of crap right now and I still can't get it to work. 


C:\Users\user\Desktop>nuitka --recurse-all test.py

scons: warning: No version of Visual Studio compiler found - C/C++ compilers 
mos
t likely not set correctly
File "C:\Python34\Lib\site-packages\nuitka\build\SingleExe.scons", line 41, 
in <
module>

scons: warning: No version of Visual Studio compiler found - C/C++ compilers 
mos
t likely not set correctly
File "C:\Python34\Lib\site-packages\nuitka\build\SingleExe.scons", line 200, 
in
createEnvironment
Error, cannot locate suitable C++ compiler. You have the following options:

a) If a suitable Visual Studio version is installed, it will not be located,
   automatically unless you install pywin32 for the Python installation
   below "c:\Python27".

b) To make it find Visual Studio execute from Start Menu the 'Visual Studio
   Command Prompt' or "vcvarsall.bat". That will add Visual Studio to the
   PATH. And it will be detected.

c) Install MinGW to 'C:\MinGW' then it is automatically picked up. But be
   sure to pick the proper variant (32/64 bits, your Python arch is 'x86'). 
If
   you have it installed, using the matching Python will help.
msg1382 (view) Author: grippa Date: 2015-07-29.01:54:56
Nuitka version 0.5.13.2
msg1381 (view) Author: grippa Date: 2015-07-29.01:51:54
64bit windows. 32bit python 3.4 and 32bit python 2.7. 32 bit microsoft 
visual studio 2015 32bit. MinGW64 32bit. 

C:\Windows\system32>nuitka --recurse-all  C:\Users\user\Desktop\test.py
Traceback (most recent call last):
  File "C:\Python34\Scripts\nuitka", line 176, in <module>
    MainControl.main()
  File "C:\Python34\Lib\site-packages\nuitka\MainControl.py", line 692, in 
main
    main_module = main_module
  File "C:\Python34\Lib\site-packages\nuitka\MainControl.py", line 624, in 
compi
leTree
    quiet       = not Options.isShowScons()
  File "C:\Python34\Lib\site-packages\nuitka\MainControl.py", line 487, in 
runSc
ons
    return SconsInterface.runScons(options, quiet), options
  File "C:\Python34\Lib\site-packages\nuitka\build\SconsInterface.py", line 
194,
 in runScons
    return subprocess.call(scons_command, shell = False) == 0
  File "C:\Python34\lib\subprocess.py", line 537, in call
    with Popen(*popenargs, **kwargs) as p:
  File "C:\Python34\lib\subprocess.py", line 859, in __init__
    restore_signals, start_new_session)
  File "C:\Python34\lib\subprocess.py", line 1112, in _execute_child
    startupinfo)
FileNotFoundError: [WinError 2] The system cannot find the file specified
History
Date User Action Args
2015-07-30 07:59:31kayhayensetstatus: chatting -> resolved
2015-07-30 07:58:55kayhayensetmessages: + msg1387
2015-07-29 14:18:37grippasetmessages: + msg1386
2015-07-29 13:58:08kayhayensetmessages: + msg1385
2015-07-29 08:17:53kayhayensetpriority: urgent -> bug
assignedto: kayhayen
title: FileNotFoundError: [WinError 2] The system cannot find the file specified -> Windows: Visual Studio 2015 is not supported
keyword: + windows
nosy: + kayhayen
2015-07-29 02:35:18grippasetmessages: + msg1383
2015-07-29 01:54:56grippasetstatus: unread -> chatting
messages: + msg1382
2015-07-29 01:51:54grippacreate