Issue223

Title 0.5.13.3 fails to import logging (regression)
Priority bug Status resolved
Superseder Nosy List kayhayen, ralsina
Assigned To kayhayen Keywords

Created on 2015-07-31.14:35:44 by ralsina, last changed by kayhayen.

Messages
msg2505 (view) Author: kayhayen Date: 2018-08-23.23:24:48
Tox integration is being worked on and tracked on Github in the future, closing 
this therefore.
msg1392 (view) Author: kayhayen Date: 2015-07-31.15:39:42
I really need to have Buildbot tests for the virtualenv setups, so users don't 
have to find this, but that will have to wait for tox integration ideally.
msg1391 (view) Author: ralsina Date: 2015-07-31.15:31:03
Awesome, thanks!
msg1390 (view) Author: kayhayen Date: 2015-07-31.15:29:28
Hello Roberto,

I have to confirm that, virtualenv support is broken right now. Dropping the 
"site" module from Nuitka run time looses PYTHONPATH, which is being preserved, 
but restored too late.
 
I have fixed this, and push out a hotfix right now, will appear shortly in the 
usual places.

Thanks for the report,
Kay
msg1389 (view) Author: ralsina Date: 2015-07-31.14:35:44
This worked with 0.5.13.2 but fails with 0.5.13.3:

$ env/bin/nuitka agent.py  
Traceback (most recent call last):
  File "env/bin/nuitka", line 31, in <module>
    import logging
ImportError: No module named 'logging'
History
Date User Action Args
2018-08-23 23:27:54kayhayensetstatus: chatting -> resolved
2018-08-23 23:24:48kayhayensetstatus: done-cbb -> chatting
messages: + msg2505
2015-07-31 15:39:42kayhayensetstatus: chatting -> done-cbb
messages: + msg1392
2015-07-31 15:31:03ralsinasetstatus: resolved -> chatting
messages: + msg1391
2015-07-31 15:29:56kayhayensetstatus: chatting -> resolved
assignedto: kayhayen
title: 0.5.13.3 fails to import logging (regressions) -> 0.5.13.3 fails to import logging (regression)
nosy: + kayhayen
2015-07-31 15:29:28kayhayensetstatus: unread -> chatting
messages: + msg1390
title: 0.5.13.3 fails to import logging -> 0.5.13.3 fails to import logging (regressions)
2015-07-31 14:35:44ralsinacreate