Issue231

Title Windows: Package import fails when binary is located in path with non-ascii characters
Priority bug Status resolved
Superseder Nosy List johan, kayhayen
Assigned To kayhayen Keywords standalone, windows

Created on 2015-08-17.08:03:40 by johan, last changed by kayhayen.

Files
File name Uploaded Type Edit Remove
Nuitka.log johan, 2015-08-17.08:03:40 application/octet-stream
Messages
msg1437 (view) Author: johan Date: 2015-08-18.10:39:47
Hello Kay,

thank you for your quick response!
I successfully tested the factory branch's latest revision.
(5efe986b9397955fbe19f5453f71d96b1cbd5622)

After rebuilding the executable with this Nuitka revision
I can run the executable from non-ascii directory paths as well.

Thank you once again for the quick fix!
/Johan
msg1436 (view) Author: kayhayen Date: 2015-08-18.07:58:51
I have just pushed something to official git repository branch factory that 
addresses it. It contains other changes that might break things.

I intend to make a hotfix release out of this. Please give it a try if you can 
and let me know if it works. Should other changes fail you, find the commit 
titled "Standalone: Fix, could not load extension modules on Windows if in 
unicode path." and git checkout to that then.

The issue is that for file system paths like LoadLibraryEx, the "ACP" encoding 
must be used, whereas elsewhere, the UFT8 needs to be used to make a unicode 
object. These are now two functions used in several places accordingly.

Yours,
Kay
msg1432 (view) Author: kayhayen Date: 2015-08-17.14:27:03
So the loading of extension modules for libraries needs some change too. I will 
look into it.
msg1431 (view) Author: johan Date: 2015-08-17.08:03:40
Hello!

I experience problems with the executable generated by Nuitka, when the
executable is put in a directory path containing non-ascii characters.


The attached log files shows:
1. How an executable file is created with Nuitka
2. How the executable file is tested in its original location
3. How the directory containing the executable file is renamed
4. How an exception is generated when the executable file is tested again

After the directory rename, import of required packages fails.

The test is run on Windows 7, Nuitka 0.5.13.6, Python 3.4.3


In some cases I cannot avoid putting the executable in a directory with
non-ascii characters, so I would very much like this problem to be solved.

Thank you!
/Johan
History
Date User Action Args
2016-03-05 19:19:08kayhayensetstatus: testing -> resolved
2015-08-18 10:39:47johansetmessages: + msg1437
2015-08-18 07:59:05kayhayensetkeyword: + standalone
2015-08-18 07:58:51kayhayensetstatus: chatting -> testing
messages: + msg1436
2015-08-17 14:27:03kayhayensetstatus: unread -> chatting
keyword: + windows
title: Package import fails when binary is located in path with non-ascii characters -> Windows: Package import fails when binary is located in path with non-ascii characters
nosy: + kayhayen
messages: + msg1432
assignedto: kayhayen
2015-08-17 08:03:40johancreate