Issue241

Title Standalone: fails to include required libs in 0.5.14.0
Priority bug Status chatting
Superseder Nosy List kayhayen, sgoodwin
Assigned To kayhayen Keywords standalone, wrong_execution

Created on 2015-09-03.20:42:59 by sgoodwin, last changed by kayhayen.

Files
File name Uploaded Type Edit Remove
log.txt sgoodwin, 2015-10-06.20:43:47 text/plain
Messages
msg1689 (view) Author: kayhayen Date: 2015-11-11.12:41:58
Any chance to attempt the bisect, or check the latest release 0.5.16?

Yours,
Kay
msg1667 (view) Author: kayhayen Date: 2015-10-27.07:16:28
The dropping back helping part should make it easy to bisect.

Please checkout the git repository.

git checkout master
git bisect bad # allow it to start one
git checkout 0.5.13.8
git bisect good

Then execute your test with bin/nuitka called with a Python version of your 
choice and either enter git bisect good or git bisect bad.

This will take few iterations and then tell you precisely which commit is too 
blame. Alternatively if you can come up with a manual reproducer, that would be 
great too.

Yours,
Kay
msg1666 (view) Author: wsiddall Date: 2015-10-27.01:20:19
Having just installed nuitka 0.5.15, I'm working on a portable build and aside 
from getting osgeo/gdal getting to import, I could not attach _sqlite3. 
Dropping to 0.5.13.8 solves the problem and the _sqlite3.pyd file is present 
in the .dist folder.
msg1638 (view) Author: sgoodwin Date: 2015-10-15.03:10:41
I'm not so sure ctypes is good - especially as it is missing.
msg1633 (view) Author: kayhayen Date: 2015-10-13.07:28:04
So ctypes looks good there.

So now I did the simplest thing "import ctypes", and found that despite --
recurse-to=ctypes, it wouldn't recurse to there on my Linux, but it does so on 
Windows, or so I think. That's something to look at.

However, I now think handling frozen modules as a separate thing entirely is 
mostly wrong and a technical debt. There need to be frozen modules as part of 
the module set being worked on, and then potentially an explicit replacement due 
to options of compiled code later on.

Having just made a new release, 0.5.15, that is unlikely to improve this issue, 
I think that this part of Nuitka basically needs a cleanup so it cannot be wrong 
anymore, or at least has the transparency to decide what is wrong.

Yours,
Kay
msg1612 (view) Author: sgoodwin Date: 2015-10-06.20:43:47
Sure thing, must've missed your last message.

This is running with the latest pre-release. There are still missing files.
msg1611 (view) Author: kayhayen Date: 2015-10-06.07:16:09
Can you please re-test with the latest pre-release. I have reason to believe it 
ought be better, or would need the output requested from --explain-imports.

Yours,
Kay
msg1572 (view) Author: kayhayen Date: 2015-09-24.06:51:24
The "_ctypes" issue ought to be solved though. Can you attach the outputs of "--
show-modules" and "--explain-imports" options from the latest pre-release?

Yours,
Kay
msg1559 (view) Author: sgoodwin Date: 2015-09-19.20:20:21
Further update - Nuitka-0.5.14pre9 works, so it seems to be something between
then and the release that is causing this.
msg1558 (view) Author: sgoodwin Date: 2015-09-19.14:32:23
I've just gotten around to trying  0.5.14.1 and I'm seeing the same behavior as
before. I'll see if I can create a simple test to reproduce it.

I went back and tried a pre release of 0.5.14 (Nuitka-0.5.14pre3) just to see
what would happen, and it worked. I can't speak for any of the other pre
releases. So it would seam that this issue is caused by some change between
Nuitka-0.5.14pre3 and 0.5.14.
msg1506 (view) Author: kayhayen Date: 2015-09-06.22:36:50
I think I traced this down to "ctypes" compiled module vs "ctypes" frozen module 
not generating all the dependencies.

This revealed an error to drop the frozen module, in fact the compiled module 
should be dropped. This also will make compilation somewhat faster as these have 
no code generated and no C compilation then.

This is part of the latest hotfix 0.5.14.1

Yours,
Kay
msg1499 (view) Author: kayhayen Date: 2015-09-04.07:16:01
That sounds like bad news. Could you make a comparative listing of the two 
.dist folders, and highlight the differences? Or would you even have a minimal 
reproducer?

I suspect a fix where compiled stuff won't be included frozen could be at 
fault, but I am not sure.

Yours,
Kay
msg1498 (view) Author: sgoodwin Date: 2015-09-03.20:42:59
I'm currently using 0.5.14 to try and build a standalone project. 
I've noticed that in this version, many required libs (that is, the files under
the Python/libs folder) are not being built/included by Nuitka. I noticed
`_ctypes` and `_sqlite3`, but there are a lot more. 
The only difference in my build environment is the Nuitka version, and
downgrading to a previous version results in the libs being built correctly. 

This is with Python3.4 x86 on Windows 8.
History
Date User Action Args
2015-11-11 12:41:58kayhayensetmessages: + msg1689
2015-10-27 07:16:28kayhayensetmessages: + msg1667
2015-10-27 01:20:19wsiddallsetmessages: + msg1666
2015-10-15 03:10:41sgoodwinsetmessages: + msg1638
2015-10-13 07:28:04kayhayensetmessages: + msg1633
2015-10-06 20:43:49sgoodwinsetfiles: + log.txt
messages: + msg1612
2015-10-06 07:16:09kayhayensetmessages: + msg1611
2015-09-24 06:51:24kayhayensetmessages: + msg1572
2015-09-19 20:20:21sgoodwinsetmessages: + msg1559
2015-09-19 14:32:23sgoodwinsetstatus: resolved -> chatting
messages: + msg1558
2015-09-06 22:36:50kayhayensetstatus: chatting -> resolved
keyword: + wrong_execution
title: 0.5.14 Standalone fails to include required libs -> Standalone: fails to include required libs in 0.5.14.0
nosy: + kayhayen
messages: + msg1506
assignedto: kayhayen
2015-09-04 07:16:01kayhayensetstatus: unread -> chatting
messages: + msg1499
keyword: + standalone
2015-09-03 20:42:59sgoodwincreate