Issue275

Title wampserver crashes at mid-execution: websocket issue?
Priority bug Status chatting
Superseder Nosy List ignacio.bosch
Assigned To Keywords

Created on 2015-12-09.15:45:24 by ignacio.bosch, last changed by marc.jofre.

Files
File name Uploaded Type Edit Remove
20151209_debug_wampserver.txt ignacio.bosch, 2015-12-09.15:45:24 text/plain
Messages
msg1784 (view) Author: marc.jofre Date: 2016-01-16.17:58:03
Hi Kay,

Similar Issue as ISSUE 259

Marc
msg1769 (view) Author: ignacio.bosch Date: 2016-01-11.09:20:33
The latest version of the autobahn does not solve the wampserver error. The 
program as a whole is still crashing at the same point. The <type 
'compiled_function'> are still visible in the cmd line before the error pops up.
msg1761 (view) Author: marc.jofre Date: 2016-01-09.13:46:02
Hi all,

Trying on this issue with the latest version of autobahn:

pip install autobahn --upgrade
msg1742 (view) Author: marc.jofre Date: 2015-12-27.08:17:31
Hi all,

When execution crashes. Debug with Microsoft Visual Studio 2008. In the stack 
call console the message below appears:

[Frames below may be incorrect and/or missing, no symbols loaded for ntdll.dll]

first change parameters, tools->option->debugging->symbol->server,yes then 
Ctrl+F5 ,then you will see amazing things

I'm pretty sure those are warnings, not errors. Your project should still run 
just fine.

However, since you should always try to fix compiler warnings, let's see what we 
can discover. I'm not at all familiar with OpenCV, and you don't link to the wiki 
tutorial that you're following. But it looks to me like the problem is that 
you're running a 64-bit version of Windows (as evidenced by the "SysWOW64" folder 
in the path to the DLL files), but the OpenCV stuff that you're trying is built 
for a 32-bit platform. So you might need to rebuild the project using CMake, as 
explained here.

More specifically, the files that are listed are Windows system files. PDB files 
contain debugging information that Visual Studio uses to allow you to step into 
and debug compiled code. You don't actually need the PDB files for system 
libraries to be able to debug your own code. But if you want, you can download 
the symbols for the system libraries as well. Go to the "Debug" menu, click on 
"Options and Settings", and scroll down the listbox on the right until you see 
"Enable source server support". Make sure that option is checked. Then, in the 
treeview to the left, click on "Symbols", and make sure that the "Microsoft 
Symbol Servers" option is selected. Click OK to dismiss the dialog, and then try 
rebuilding.
msg1740 (view) Author: ignacio.bosch Date: 2015-12-22.16:20:52
I have compiled the new version of Nuitka, to check if somehow the issue was 
solved. It stopped prompting the same error at the same point of the execution. 
I was thinking that this may be an issue related not specifically to the 
wampserver application, but to the websocket communication protocols between 
python and the wampserver, because I think I remember seeing some warnings on 
the console after the Nuitka compilation related to this.

As a side note, the messages prompted in the command line by the program before 
giving the wampserver crash were:

<type 'compiled_function'>
<type 'compiled_function'>
<type 'compiled_function'>
<type 'compiled_function'>

Any thoughts about this issue?
msg1737 (view) Author: ignacio.bosch Date: 2015-12-09.15:45:24
Hello,

I was able to successfully create an .exe file for the project, I was even able 
to run to some extent full blocks of the program. The thing is that, at mid 
execution of the second "block", I received a windows error about wampserver 
crashing and the option to debug it. Debugging it with Visual Studio gives me 
mainly 2 messages: either "can not open PDB file" or "binary was not build with 
debug information". All of these messages are shown for .pdb and .dll files.

I attach the log with the information I am speaking about, although I am not 
that sure if it will be very enlightning... If you do require any extra 
information or something to do when replicating the error, please do tell me and 
I will try to provide this information asap.
History
Date User Action Args
2016-01-16 17:58:03marc.jofresetmessages: + msg1784
2016-01-11 09:20:33ignacio.boschsetmessages: + msg1769
2016-01-09 13:46:02marc.jofresetmessages: + msg1761
2015-12-27 08:17:31marc.jofresetmessages: + msg1742
2015-12-22 16:21:30ignacio.boschsettitle: wampserver crashes at mid-execution -> wampserver crashes at mid-execution: websocket issue?
2015-12-22 16:20:52ignacio.boschsetstatus: unread -> chatting
messages: + msg1740
2015-12-09 15:45:24ignacio.boschcreate