Issue295

Title Standalone on Linux with Anacaonda - no Python .so library in .dist folder
Priority bug Status testing
Superseder Nosy List jrenner
Assigned To Keywords standalone

Created on 2016-02-25.17:25:57 by jrenner, last changed by kayhayen.

Messages
msg1862 (view) Author: kayhayen Date: 2016-03-06.10:31:16
Just made a pre-release with this included.
msg1857 (view) Author: kayhayen Date: 2016-03-05.19:08:00
For accelerated mode, it's necessary to set PYTHONHOME. The new code passes the 
python prefix of AnaConda to the compile time and sets PYTHONHOME from it. That 
should do.

For standalone mode, the rpath is extended by the lib directory where libpython 
lives. Without that it was using the system libpython from regular python 
installation. Worked for me nicely this way.

It's currently in factory, but soon to be included in a pre-release.

http://nuitka.net/doc/factory.html

Yours,
Kay
msg1856 (view) Author: kayhayen Date: 2016-03-05.14:39:45
For Anaconda, not finding the DLL is kind of normal in acceleration mode, 
largely because Anaconda has no real installation, and acceleration mode is not 
yet adapted to that.

I was planning to do this for Windows Anaconda and CPython3.5 which also does 
not install the DLL to the system anymore it seems.

Anaconda on Linux is not supported so far, but I will try and add support for 
it, at the same time.

Yours,
Kay
msg1840 (view) Author: jrenner Date: 2016-02-25.17:32:21
Actually I have the same problem with a program that has been compile without 
standalone, and no arguemnts at all.

i.e. "nuitka hello_world.py"
./hello_world.exe
msg1839 (view) Author: jrenner Date: 2016-02-25.17:27:18
I forgot to mention:

Nuitka version: 0.5.20pre1
msg1838 (view) Author: jrenner Date: 2016-02-25.17:25:57
I'm trying to compile a completely standalone executable on linux (for linx). I 
am using Anacaonda and Python 3.5.

after running "nuitka --standalone" the exe in the .dist folder comlplains 
about a missing libpython3.5m.so.1.0, there are other library files in the dist 
folder, but it seems like the standard python so files are not there.  I 
created symlinks to all the .so files in my Anaconda lib folder and the program 
worked once I did that.
History
Date User Action Args
2016-03-06 10:31:16kayhayensetmessages: + msg1862
2016-03-05 19:08:00kayhayensetstatus: chatting -> testing
messages: + msg1857
keyword: + standalone
2016-03-05 14:39:45kayhayensetmessages: + msg1856
2016-02-25 17:32:21jrennersetmessages: + msg1840
2016-02-25 17:27:18jrennersetstatus: unread -> chatting
messages: + msg1839
2016-02-25 17:25:57jrennercreate