Issue324

Title wxPython standalone application on OSX: Framework build
Priority bug Status unread
Superseder Nosy List jonaspf
Assigned To Keywords

Created on 2016-10-02.19:06:09 by jonaspf, last changed by jonaspf.

Messages
msg1979 (view) Author: jonaspf Date: 2016-10-02.19:06:09
When I run a wxPython standalone application using nuitka on OSX El Capitan, I 
get the following error:

This program needs access to the screen.
Please run with a Framework build of python, and only when you are
logged in on the main display of your Mac.

Steps to reproduce:

1. Copy the following into test.py
    import wx

    app = wx.App(False)
    frame = wx.Frame(None, wx.ID_ANY, "Hello World")
    frame.Show(True)
    app.MainLoop()
2. nuitka --standalone test.py
3. cd test.dist && ./test.exe

Additional information:

- I'm using the cocoa port of wxPython
- I had to patch wxPython as described in http://trac.wxwidgets.org/ticket/16329 
in order to build it on 
OSX
- I tried the out-of-the-box python in /usr/bin/python as well as the lastest 
python from brew. Same issue 
with both
- A similar issue comes up when using a virtualenv (without nuitka). A workaround 
is described here: 
https://wiki.wxpython.org/wxPythonVirtualenvOnMac

My workaround:

- It works if I create a module instead of a standalone application and call that 
with the system python
History
Date User Action Args
2016-10-02 19:06:09jonaspfcreate