Issue336

Title --recurse-directory doesn't work for django apps
Priority bug Status resolved
Superseder Nosy List nick
Assigned To Keywords

Created on 2016-11-07.19:03:08 by nick, last changed by kayhayen.

Files
File name Uploaded Type Edit Remove
testprj.tar.bz2 nick, 2016-11-07.19:03:08 application/x-bzip2
Messages
msg2487 (view) Author: kayhayen Date: 2018-08-23.22:16:10
Lack of feedback, my solution likely works.
msg2371 (view) Author: kayhayen Date: 2018-04-09.21:54:33
There is a new option --include-package in the factory branch, use this instead. 
Using --recurse-directory should become unnecessary with it.
msg2048 (view) Author: nick Date: 2016-11-07.19:03:08
Hi,

I'm trying to compile a django project with Nuitka, but run into a problem. As django doesn't 
use any 
explicit imports for project apps I need to compile it using --recurse-directory option for 
each app. 
But it still doesn't work.

Software versions I use:

Ubuntu 16.04
Python 3.5.2
Nuitka 0.5.23.1

A sample django project is attached to the current issue.

Here is the command I run and the output. In the resulting wsgi.so file classes from "testapp" 
package 
aren't included.

(venv) ubuntu@ubuntu-xenial:~/testprj$ nuitka --verbose --recurse-directory=testapp --module 
testprj/wsgi.py
Nuitka:DEBUG:Checking top level plug-in path testapp None
Nuitka:DEBUG:Checking detail plug-in path 'testapp' 'None':
None Default behavior, not recursing without request.
Nuitka:WARNING:Not recursing to 'django.core.wsgi' (/home/ubuntu/venv/lib/python3.5/site-
packages/django/core/wsgi.py), please specify --recurse-none (do not warn), --recurse-all 
(recurse to 
all), --recurse-not-to=django.core.wsgi (ignore it), --recurse-to=django.core.wsgi (recurse to 
it) to 
change.

Any help appreciated. Thanks.
History
Date User Action Args
2018-08-23 22:16:10kayhayensetstatus: testing -> resolved
messages: + msg2487
2018-04-09 21:54:34kayhayensetstatus: unread -> testing
messages: + msg2371
2016-11-07 19:03:08nickcreate