Issue357

Title Error on first use on Xenial Ubuntu
Priority feature Status unread
Superseder Nosy List vincelewis1968
Assigned To Keywords

Created on 2017-03-10.09:21:16 by vincelewis1968, last changed by vincelewis1968.

Messages
msg2130 (view) Author: vincelewis1968 Date: 2017-03-10.09:21:16
Hi. I installed the stable Xenial release from here on your website:
http://nuitka.net/deb/stable/xenial/pool/main/n/nuitka/nuitka_0.5.25+ds-1_all.deb

Tried to compile a script but put in the wrong python version 
that is I typed this:
nuitka --recurse-on --python-version=3.4 myscript.py

instead of this:
nuitka --recurse-on --python-version=3.5 myscript.py

I dont get a warning, instead I get the following cryptic error:
Traceback (most recent call last):
  File "/usr/bin/nuitka", line 162, in <module>
    Execution.callExec(args)
  File "/usr/share/nuitka/nuitka/utils/Execution.py", line 42, in callExec
    os.execl(*args)
  File "/usr/lib/python2.7/os.py", line 314, in execl
    execv(file, args)
OSError: [Errno 2] No such file or directory

This is a (small) feature request. 
Otherwise it did compile an exe which ran - well done :)
History
Date User Action Args
2017-03-10 09:21:16vincelewis1968create