Issue405

Title Application error 0xc000007b when try to start compiled Python source file
Priority bug Status resolved
Superseder Nosy List kayhayen, tav
Assigned To kayhayen Keywords

Created on 2018-07-15.10:44:20 by tav, last changed by kayhayen.

Messages
msg2492 (view) Author: kayhayen Date: 2018-08-23.23:02:21
I am closing this then. I have no idea why it didn't work with MSVC, but we are 
not going to find out, hopefully the issue will resurface elsewhere with better 
indications.
msg2491 (view) Author: tav Date: 2018-08-23.23:00:49
No, there is no non-ascii characters in that directory.

2018-08-24 8:13 GMT+10:00 Kay Hayen (via Issue Tracker) <
issue_tracker@nuitka.net>:

>
> Kay Hayen <kay.hayen@gmail.com> added the comment:
>
> You didn't tell me if you have non-ascii characters in the directory you
> executed the MSVC compiled binary in. Is that the case?
>
> Yours,
> Kay
>
> ----------
> assignedto:  -> kayhayen
> nosy: +kayhayen
>
> _______________________________________________
> Nuitka issue tracker <issue_tracker@nuitka.net>
> <http://bugs.nuitka.net/issue405>
> _______________________________________________
>
msg2485 (view) Author: kayhayen Date: 2018-08-23.22:13:34
You didn't tell me if you have non-ascii characters in the directory you 
executed the MSVC compiled binary in. Is that the case?

Yours,
Kay
msg2455 (view) Author: kayhayen Date: 2018-08-06.18:12:29
When you specify --mingw then it should be used. I think MSVC 2017 ought to win if installed, so it 
ought to be good already. Using an older one normally should not be the issue. Uninstall 2013 if 
you can and report if that changes something though, maybe the preference order is not what I think 
it is.

Potentially the issue is non-UTF8 / special characters. Can you try and compile in a directory with 
plain ASCII file names? Maybe that is why MinGW works better for you. These issues are a bit hard 
to get by for me.

Yours,
Kay
msg2445 (view) Author: tav Date: 2018-07-25.12:11:18
I have both MSVC 2013 and MSVC 2017 installed. How can I select which
compiler to use? I've tried --msvc=12.0 option, but nuitka still uses MinGW
(exe file is the same after compiling with --mingw and with --msvc=12.0).

2018-07-25 21:07 GMT+10:00 Kay Hayen (via Issue Tracker) <
issue_tracker@nuitka.net>:

>
> Kay Hayen <kay.hayen@gmail.com> added the comment:
>
> What MSVC version that that?
>
> _______________________________________________
> Nuitka issue tracker <issue_tracker@nuitka.net>
> <http://bugs.nuitka.net/issue405>
> _______________________________________________
>
msg2444 (view) Author: kayhayen Date: 2018-07-25.11:06:59
What MSVC version that that?
msg2433 (view) Author: tav Date: 2018-07-19.23:56:41
Yes, MSVC was used by default. With MinGW64 it's working!
But performance results are not so impressive (Nuitka's generated exe works 
just 1.5x faster than Python).
Btw which memory allocator are you using? Can I use custom memory allocator 
like lockless[http://locklessinc.com/downloads/] or 
ltalloc[alextretyak.github.io/ltalloc/wiki.htm]?
msg2430 (view) Author: kayhayen Date: 2018-07-19.13:09:20
That is pretty bad, which C compiler are you using? If MSVC, can you try MinGW64 
or vice versa?

Yours,
Kay
msg2429 (view) Author: tav Date: 2018-07-17.00:29:56
I have tried
python.exe -m nuitka --python-flag=-v pqmarkup.py
but there is no any output.
msg2428 (view) Author: kayhayen Date: 2018-07-16.08:52:32
Include --python-flag=-v and past the output, esp. the last imports before the 
failure. It would likely indicate where things go bad.

Yours,
Kay
msg2427 (view) Author: tav Date: 2018-07-15.10:44:20
When I run pqmarkup.exe the following error message is showed:
---------------------------
pqmarkup.exe - Ошибка приложения
---------------------------
Ошибка при запуске приложения (0xc000007b). Для выхода из приложения нажмите 
кнопку "ОК". 
---------------------------
ОК   
---------------------------

I obtained pqmarkup.exe with following command:
    python.exe -m nuitka pqmarkup.py
where pqmarkup.py is a Python file, which can be obtained at 
[https://bitbucket.org/pqmarkup/pqmarkup/raw/default/pqmarkup.py].

My OS: Windows 8.1 64-bit
Python version is 3.6.6
I installed Nuitka from Nuitka-5.1.310.win-amd64.py36.msi
History
Date User Action Args
2018-08-23 23:02:21kayhayensetstatus: in-progress -> resolved
messages: + msg2492
2018-08-23 23:00:49tavsetmessages: + msg2491
2018-08-23 22:13:46kayhayensetstatus: chatting -> in-progress
2018-08-23 22:13:35kayhayensetassignedto: kayhayen
messages: + msg2485
nosy: + kayhayen
2018-08-06 18:12:29kayhayensetmessages: + msg2455
2018-07-25 12:11:18tavsetmessages: + msg2445
2018-07-25 11:07:00kayhayensetmessages: + msg2444
2018-07-19 23:56:41tavsetmessages: + msg2433
2018-07-19 13:09:20kayhayensetmessages: + msg2430
2018-07-17 00:29:56tavsetmessages: + msg2429
2018-07-16 08:52:32kayhayensetstatus: unread -> chatting
messages: + msg2428
2018-07-15 10:44:20tavcreate