Issue421

Title This application failed to start because it could not find or load the Qt platform plugin "xcb"
Priority bug Status chatting
Superseder Nosy List darkpenguin
Assigned To Keywords

Created on 2019-03-18.01:26:24 by darkpenguin, last changed by darkpenguin.

Messages
msg2558 (view) Author: darkpenguin Date: 2019-03-18.08:12:11
Oh, sorry. Google did not show me that there is a Github page for
Nuitka, even though I suspected that there might be. :)
msg2557 (view) Author: kayhayen Date: 2019-03-18.07:44:04
Sorry about no having closed this for new issues yet, can you raise it in the new 
issue tracker on Github instead. It seems the issue template will serve us well.
msg2556 (view) Author: darkpenguin Date: 2019-03-18.01:26:23
I'm building a "hello world" with PyQt5 with options:

nuitka3 test.py --show-progress --recurse-stdlib --standalone

The resulting binary does not work:

This application failed to start because it could not find or load the Qt
platform plugin "xcb".
Reinstalling the application may fix this problem.
Aborted (core dumped)

This happens even on the system where I built it.

Adding "--plugin-enable=qt-plugins" does not help.

Also, my application includes a "test mode": if I run it with "--test", it
prints a line "Test passed" and exits before importing anything PyQt-related.
And launching it this way works!

I saw #274 mentioning something similar, but it also mentions a lot of other things.

Actually, I just had the same issue with PyInstaller, but then I updated it to
the latest version, and now it's fixed.

I tried this on Debian Jessie, Debian Stretch and Ubuntu Cosmic, with stable
Nuitka and with development Nuitka.
History
Date User Action Args
2019-03-18 08:12:11darkpenguinsetmessages: + msg2558
2019-03-18 07:44:04kayhayensetstatus: unread -> chatting
messages: + msg2557
2019-03-18 01:26:25darkpenguincreate